Archive

Posts Tagged ‘ExpiresActive’

500 Internal Server Error – Apache config vs. WP-Super-Cache

September 9th, 2009 No comments

Den ganzen Tag war die Seite nicht ereichbar. Alle Besucher (ausser mir) sahen nur ein:

500 Internal Server Error

Als eingeloggter User bekam ich eine andere Seite serviert und sah diesen Fehler nicht. Einzig die Tatsache, dass der Traffic total eingebrochen ist machte mich stutzig. An dieser Stelle vielen Dank an Wolfgang Klenk, der mich bei Facebook darauf aufmerksam machte, dass mein Server nicht richtig funktioniert. Die Fehlerlogdatei enthielt massenhaft folgende Fehlermeldung:

wp-content/cache/.htaccess: ExpiresActive not allowed here

Der Übeltäter war das WP-Super-Cache Plugin in Kombination mit meiner Apache Konfiguration. Meine Direktory Direktive im Virtualhost Eintrag sah so aus:

<directory "/var/www/htdocs/www.christophbuente.de">
   Options FollowSymLinks
   AllowOverride FileInfo
   Order allow,deny
   Allow from all
 </directory>

Wie in der readme.txt des WP-Super-Cache plugins zu lesen ist, wird aber für die AllowOverride Option der Wert All vorausgesetzt. Nachdem ich das nun angepasst habe, ist der Server auch wieder. Hier die richtige Konfiguration.

<directory "/var/www/htdocs/www.christophbuente.de">
   Options FollowSymLinks
   AllowOverride All
   Order allow,deny
   Allow from all
 </directory>

Vielleicht bewahrt es jemanden in er Zukunft vor dem gleichen Problem. Mich auf jeden Fall!